WI-FI connectivity issues

Incident Report for Langara IT

Resolved

This incident has been resolved.
Posted Mar 17, 2026 - 12:56 PDT

Investigating

IT is investigating reports that some employee computers lost connection to Wifi on main campus.
This does not impact personal devices connecting to Eduroam network.
Posted Mar 17, 2026 - 11:10 PDT
This incident affected: Networking (Wireless).