Workday outage

Incident Report for Langara IT

Resolved

Workday was able to resolve the issues on their end, restoring Workday access globally.
Posted Feb 20, 2026 - 12:20 PST

Identified

We are experiencing a Workday outage due to a vendor issue, affecting users globally.
Posted Feb 20, 2026 - 11:07 PST
This incident affected: Workday.